SugarCRM SupportPoliciesSupported Platforms

Supported Platforms

Sugar 10.2.x Supported Platforms

 This release is only available for SugarCloud customers.
End User Requirements
Client Browser Supported Versions Sugar Version(s) Comments
Google Chrome 85 10.2.0  
Microsoft Edge 85 10.2.0 Microsoft Edge is not compatible with the SugarLive functionality available in the Sugar Serve product.
Firefox 80 10.2.0  
Internet Explorer 11 10.2.0 Compatibility mode not supported.
Internet Explorer is not compatible with the SugarLive functionality available in the Sugar Serve product.
Safari 13 10.2.0 Private Browsing mode not supported.
Safari is not compatible with the SugarLive functionality available in the Sugar Serve product.

For an updated list of supported Sugar versions, please refer to the Supported Versions page.

Sugar 10.1.x Supported Platforms

 This release is only available for SugarCloud customers.
End User Requirements
Client Browser Supported Versions Sugar Version(s) Comments
Google Chrome 83 10.1.0  
Microsoft Edge 83 10.1.0  
Firefox 77 10.1.0  
Internet Explorer 11 10.1.0 Compatibility mode not supported
Safari 13 10.1.0 Private Browsing mode not supported  

For an updated list of supported Sugar versions, please refer to the Supported Versions page.

Sugar 10.0.x Supported Platforms

Please note that while the below components are necessary for running the Sugar application, it is outside the scope of our support to assist with the upgrading and maintenance of these components.

Server Requirements
Component Supported Versions Comments
Platform    
Linux/Unix/Mac OS Any platform version that supports PHP from http://php.net Sugar does not support any specific NAS or SAN devices. Performance, throughput, and configuration issues should be addressed by your storage vendor. Sugar performs testing with the NFS protocol and Linux-based clients and achieves acceptable levels of performance.
Windows Windows Server 2016  
PHP 7.3  
Database    
MySQL 5.7  
DB2 11.1

Supported for Sugar Ultimate and Enterprise only

Oracle 19

Supported for Sugar Ultimate and Enterprise only

SQL Server 2017

Sugar only supports the use of Microsoft SQL Server in conjunction with the following:

  • Windows Server Environment
  • IIS Web Server
  • Microsoft SQL Server Driver for PHP

Please use the driver version that corresponds with your version of PHP. For more information, please refer to Microsoft's System Requirements for the PHP SQL Driver documentation.

Web Server    
Apache 2.4  
IIS 10 Sugar only supports IIS with the Microsoft SQL Server database
Applications Supported Versions Sugar Version(s)  
Elasticsearch 5.4, 5.6, 6.2, 6.8 10.0.0 - 10.0.2 For more information, see:
http://www.elasticsearch.org/download/
End User Requirements
Client Browser Supported Versions Sugar Version(s) Comments
Google Chrome   84 10.0.2  
81 10.0.1  
80 10.0.0  
Microsoft Edge 84 10.0.2  
81 10.0.1  
80 10.0.0  
Firefox   79 10.0.2  
75 10.0.1  
74 10.0.0  
Internet Explorer 11 10.0.0 - 10.0.2 Compatibility mode not supported
Safari  13 10.0.0 - 10.0.2 Private Browsing mode not supported  

For an updated list of supported Sugar versions, please refer to the Supported Versions page. 

Sugar 9.0.x Supported Platforms

Please note that while the below components are necessary for running the Sugar application, it is outside the scope of our support to assist with the upgrading and maintenance of these components.

Server Requirements
Component Supported Versions Comments
Platform    
Linux/Unix/Mac OS Any platform version that supports PHP from http://php.net Sugar does not support any specific NAS or SAN devices. Performance, throughput, and configuration issues should be addressed by your storage vendor. Sugar performs testing with the NFS protocol and Linux-based clients and achieves acceptable levels of performance.
Windows Windows Server 2016  
PHP 7.1, 7.3  
Database    
MySQL 5.7  
DB2 LUW 10.5

Supported for Sugar Ultimate and Enterprise only

Oracle 12c

Supported for Sugar Ultimate and Enterprise only

SQL Server 2017

Sugar only supports the use of Microsoft SQL Server in conjunction with the following:

  • Windows Server Environment
  • IIS Web Server
  • Microsoft SQL Server Driver for PHP

Please use the driver version that corresponds with your version of PHP. For more information, please refer to Microsoft's System Requirements for the PHP SQL Driver documentation.

Web Server    
Apache 2.4  
IIS 10 Sugar only supports IIS with the Microsoft SQL Server database.
Applications Supported Versions Sugar Version(s)  
Elasticsearch 5.4, 5.6, 6.2, 6.8 9.0.0 - 9.0.4 For more information, see:
http://www.elasticsearch.org/download/
End User Requirements
Client Browser Supported Versions Sugar Version(s) Comments
Google Chrome   84 9.0.4  
80 9.0.3  
76 9.0.2  
74 9.0.1  
72 9.0.0  
Firefox   79 9.0.4  
73 9.0.3  
68 9.0.2  
67 9.0.1  
65 9.0.0  
Internet Explorer 11 9.0.0 - 9.0.4 Compatibility mode not supported
Safari  13 9.0.3 - 9.0.4  
12 9.0.0 - 9.0.2 Private Browsing mode not supported  

For an updated list of supported Sugar versions, please refer to the Supported Versions page. 

Sugar 8.0.x Supported Platforms

Please note that while the below components are necessary for running the Sugar application, it is outside the scope of our support to assist with the upgrading and maintenance of these components.

Server Requirements
Component Supported Versions Comments
Platform    
Linux/Unix/Mac OS Any platform version that supports PHP from http://php.net Sugar does not support any specific NAS or SAN devices. Performance, throughput, and configuration issues should be addressed by your storage vendor. Sugar performs testing with the NFS protocol and Linux-based clients and achieves acceptable levels of performance.
Windows Windows Server 2012 R2  
PHP 7.1  
Database    
MySQL 5.7  
DB2 LUW 10.5

Supported for Sugar Ultimate and Enterprise editions only

Oracle 12c

Supported for Sugar Ultimate and Enterprise editions only

SQL Server 2014 SP2

Sugar only supports the use of Microsoft SQL Server in conjunction with the following:

  • Windows Server Environment
  • IIS Web Server
  • Microsoft SQL Server Driver for PHP

Please use the driver version that corresponds with your version of PHP. For more information, please refer to Microsoft's System Requirements for the PHP SQL Driver documentation.

Web Server    
Apache 2.4  
IIS 8.5 Sugar only supports IIS with the Microsoft SQL Server database.
Applications Supported Versions Sugar Version(s)  
Elasticsearch 5.4, 5.6 8.0.0 - 8.0.8 For more information, see:
http://www.elasticsearch.org/download/
6.2 8.0.1 - 8.0.8  
End User Requirements
Client Browser Supported Versions Sugar Version(s) Comments
Google Chrome   85 8.0.8  
84 8.0.7  
80 8.0.6  
76 8.0.4 - 8.0.5  
72 8.0.3  
69 8.0.2  
65 8.0.0 - 8.0.1  
Firefox   81 8.0.8  
79 8.0.7  
73 8.0.6  
69 8.0.5  
68 8.0.4  
65 8.0.3  
62 8.0.2  
59 8.0.0 - 8.0.1  
Internet Explorer 11 8.0.0 - 8.0.8 Compatibility mode not supported
Safari  12 8.0.3 - 8.0.8 Private Browsing mode not supported  
11 8.0.0 - 8.0.2

For an updated list of supported Sugar versions, please refer to the Supported Versions page. 

Sugar Discover Supported Platforms

Sugar Product Sugar Deployment Discover Dashlet Package
Browser Versions
Sugar Sell
Sugar Ultimate
Sugar Enterprise
Sugar Professional
SugarCloud only Discover Dashlet Package 3.0 For information regarding the supported browser versions, please refer to the Supported Platforms page specific to your version of Sugar.

Sugar Integrate Supported Platforms

Sugar Integrate

Sugar Product Sugar Versions Comments
Sugar Sell 10.0.x, 10.1.x, 10.2.x  
Sugar Serve 10.0.x, 10.1.x, 10.2.x  
Sugar Ultimate  8.0.x, 9.0.x, 10.0.x, 10.1.x, 10.2.x Use Sugar Enterprise Adapter
Sugar Enterprise 8.0.x, 9.0.x, 10.0.x, 10.1.x, 10.2.x  
Sugar Professional 8.0.x, 9.0.x, 10.0.x, 10.1.x, 10.2.x  

Sugar Integrate Templates

Sugar Integrate Template Sugar Products Sugar Versions Compatible Adapters
Opportunity To Cash Template 1.2 Sugar Sell
Sugar Ultimate
Sugar Enterprise
10.0.x, 10.1.x, 10.2.x

Quickbooks Online REST
NetSuite ERP

CRM Data Migrator for Sales 1.1 Sugar Sell
Sugar Ultimate
Sugar Enterprise
10.0.x, 10.1.x, 10.2.x Salesforce Sales Cloud
Salesforce Sales Cloud Migration (requires Data Loader license)

SugarCloud Services Supported Platforms

SugarCloud Services Application Versions Browser Versions
SugarCloud Insights Sugar 10.0.x, 10.1.x, 10.2.x For information regarding the supported browser versions, please refer to the Supported Platforms page specific to your version of Sugar.
SugarIdentity Sugar 9.0.x, 10.0.x, 10.1.x, 10.2.x
MS Outlook Plug-in 2.7.1
Sugar Connect (latest released version)
Sugar Discover (latest released version)
Sugar Mobile 25.0

Note: Only some SugarCloud instances use SugarIdentity. Refer to the SugarIdentity Guide to determine if yours is configured to do so. Existing customers will be notified before their instances begin using the service.

Connectors Supported Platforms

Connector Connector Version Sugar Versions
Customer Journey Plug-in by Addoptify 5.4.0 8.0.x, 9.0.x, 10.0.x, 10.1.x, 10.2.x
Hint 5.3.3 8.0.x, 9.0.x, 10.0.x, 10.1.x, 10.2.x
Sugar Connector for LinkedIn Sales Navigator 1.3.0 8.0.x, 9.0.x, 10.0.x, 10.1.x, 10.2.x
Sugar Connector for Marketo 3.1.9 9.0.x, 10.0.x, 10.1.x, 10.2.x
3.1.8 8.0.x

Mobile Supported Platforms

For more information including links to download Sugar's mobile products, please refer to the Mobile Solutions page.

Mobile Solution Sugar Versions Phone Devices (OS) Tablet Devices (OS)
Sugar Mobile 8.0.x, 9.0.x, 10.0.x, 10.1.x, 10.2.x iPhone (10.0 - 13.6.1)
Android (5.0 - 10.0)
iPad (10.0 - 13.6.1)
Android (5.0 - 10.0)
Mobile Browser Access

8.0.x, 9.0.x, 10.0.x, 10.1.x, 10.2.x

Safari on iPhone (10.0 - 13.6.1)
Chrome on Android (5.0 - 10.0)
The desktop version of Sugar is supported for Safari on iOS and Chrome on Android, but accessing Sugar via tablet browsers is not the optimal experience.

MACS Browser Compatibility

Sugar's Mobile Application Configuration Service is supported in the following browser versions:

Browser Supported Versions Comments
Google Chrome 57  
Safari 10.1 Private Browsing mode is not supported.

 

For an updated list of supported browser versions for Sugar, please refer to the Supported Versions page.

Plug-ins Supported Platforms

Plug-in Sugar Versions Software Versions Dependencies
Sugar Connect

8.0.x, 9.0.x, 10.0.x, 10.1.x, 10.2.x

G Suite (Chrome browser only)
Outlook for Microsoft 365 on the Web 1, 6
Outlook for Microsoft 365 (macOS) 1, 5
Outlook for Microsoft 365 (Windows 10) 1, 6, 7
 
MS Excel Plug-in 2, 3 8.0.x, 9.0.x, 10.0.x, 10.1.x, 10.2.x Excel 2013
Excel 2016
Excel 2019
Office 365 ProPlus  1
.NET Framework 4.0 4, 4.5
Visual Studio Tools for Office 2010 Runtime
MS Outlook Plug-in 2, 3 8.0.x, 9.0.x, 10.0.x, 10.1.x, 10.2.x Outlook 2013
Outlook 2016
Office 365 1
.NET Framework 4.5+
Visual Studio Tools for Office 2010+ Runtime
MS Word Plug-in 2, 3 8.0.x, 9.0.x, 10.0.x, 10.1.x, 10.2.x Word 2013
Word 2016
Word 2019
Office 365 ProPlus 1
.NET Framework 4.0 4, 4.5
Visual Studio Tools for Office 2010 Runtime

Semi-Annual Channel
MS Excel, Outlook, and Word Plug-ins are supported on the Windows operating system only. 
MS Excel, Outlook, and Word Plug-ins are not supported in Terminal Server environments.
4 Service Pack 3 (SP3) is required for Windows XP to be able to install .NET Framework 4.
5 The new Outlook for Mac, available in the Apple App Store and released in 2020, is not supported with Sugar Connect. Outlook for Microsoft 365 for Mac must be acquired directly from Microsoft. 
6 Internet Explorer is not supported with Sugar Connect.
7 Outlook for Microsoft 365 must be on version 16.0.11629 or greater combined with Windows 10 version 1903 or greater to ensure that the Microsoft Edge browser is used for the Sugar Connect add-in. For more information, refer to Microsoft's Browsers used by Office Add-ins documentation.

For an updated list of supported Sugar versions, please refer to the Supported Versions page.

Sugar Market Supported Platforms

Supported CRM Versions

CRM Connector Supported CRM Versions
Microsoft Dynamics 2015
2016
365 version 9
Infor 8.2 - 8.4
SugarCRM 8.0, 9.0, 10.0, 10.1, 10.2
Only supported on MSSQL and MySQL; SugarCRM on other databases is not supported (e.g. Oracle, DB2).
Sage CRM 2017
2018 R3
  2019 R1 and R2

Salesforce

(Classic or Lightning)

Unlimited Edition
Enterprise Edition
Developer Edition
Professional Edition (only with API add-on)
Netsuite Online
Bullhorn Online

 

Supported Browser Versions

Client Browser Supported Versions Comments
Google Chrome 49 or higher  
Firefox 45 or higher  
Internet Explorer 11 or higher Compatibility mode not supported
Safari 9 or higher Private Browsing mode not supported  
Edge 13 or higher