SugarCRM SupportHelp ArticlesInstallation and UpgradeTroubleshooting Health Check OutputHealth Check Error: Incompatible Monolog Customization

Health Check Error: Incompatible Monolog Customization

Overview

The Health Check wizard must be run when upgrading to evaluate your instance's ability to move to the target version. During the health check, various types of issues may be detected, which can affect your ability to upgrade. This article will cover how to resolve a "Incompatible Monolog Customization" error reported by the health check.

Symptoms

This error generates the warning, "Incompatible Monolog Customization", in health check.

Resolution

In Sugar 12.3 (Q1 2023), Sugar upgraded from Monolog 1.x to 2.x. Significant changes exist between Monolog 1.x to 2.x that require attention and possible refactoring of your customizations. The Sugar upgrader was configured to identify known incompatibilities with Monolog 2.x that will need to be fixed before proceeding with the upgrade.

The upgrader will generate a health check error if it encounters anything unusual such as incompatible Monolog customizations. Please refer to the Developer Blog in the SugarClub community for additional information and the steps needed to resolve this health check error.

Last modified: 2023-01-13 16:45:53